티스토리 뷰

반응형

개요

 

아래 항목을 최대한 간단히 들여다 보려

1. WSL 에서 VIM 사용하려고 보니 7점대 version 이다. 최신 버전 설치하자

2. 최신버전 설치 가이드를 보니 apt-get 아니라 apt 쓰네? 이거 뭔지 들여다 보자.

 

* (참고) WSL (Windows Subsystem for Linux) == Bash on Ubuntu on Windows

 

 

vim 최신으로 update 하기

 

원문링크: https://itsfoss.com/vim-8-release-install/

 

TL;DR. 그냥 아래만 치면 된다.

sudo add-apt-repository ppa:jonathonf/vim

sudo apt update

sudo apt install vim

 

PPA란 무엇인가

 

- 링크: https://deviantcj.tistory.com/24

- 안정적인 우분투 소프트웨어 센터에서 가져와 설치하기보다

- PPA (Personal Package Archive) 에서 가져올 수 있다.

- PPA 를 추가하는 명령어가 바로 add-apt-repository 이다.

 

그냥 sudo apt-get install vim 을 하면 우분투 소프트웨어 센터에서는 vim 7점대 버전을 설치해주는데

PPA 인 jonathonf/vim 저장소를 추가한다음 설치하면 최신 vim 을 설치할 수 있는 것이다.

 

apt vs apt-get

 

가끔 리눅스를 쓰면 apt-get 을 써왔는데 apt 라는게 불쑥 튀어나와서 구글링 해봄

- 링크: https://itsfoss.com/apt-vs-apt-get-difference/

 

TL;DR. apt 를 써라

좀더 잡다한 이야기는 아래에.

 

(참고) Linux Mint 에서는 apt 라는 apt-get 의 python wrapper 로서 여기서 이야기는 apt 와는 다르다.

 

1) Debian 에서는 APT (Advanced Packaging Tool) 을 제공함

2) Debian 의 APT 와 연동하는 다양한 툴이 있음.

- 대표적인게 apt-get, Aptitude

3) 그런데 apt-get 을 쓰면 apt-cache 등등의 commands 를 만나게 됨

점점 지저분해짐

 

그래서 apt command 가 나왔습니다.

 

apt-get, apt-cache 에서 많이 쓰이는 놈들만 잘 추려낸 것이 apt

따라서, 일반적인 (Debian 계열) Linux 사용자라면 apt 만 써도 충분하다.


반응형
댓글
댓글쓰기 폼